Bir Gün Buzdolabınız da İnternete Bağlı Olacak!

Bu cümleyi bir çok dersim de öğrencilerime söylemişimdir ve sanırım pek azı bana hak verdi 🙂 Ama ben ümitliyim, eve varmadan evde ne yemek kalmış bir gün öğreniceğiz!

Nerden çıktı bu diyeceksiniz; Bir süre önce yeni nesil bir lcd televizyonu kurcalama şansım oldu. “Televizyon mu, router olmasın bak”  diyenleri duyar gibiyim sanki 🙂 Yok yok, doğru televizyon cidden. Neden mi?? Çünkü yeni nesil televizyonların çoğu network”e bağlanabilmekte. Ama çok az insan televizyonlarını ağa dahil edip ne yaptığını keşfetmiş durumda.

Meraklı ben, televizyonla tanıştığım ilk an napıp edip cihaza UTP kablo ulaştırdım 🙂  Neler yapabildiğini cidden merak ediyordum. Açıkcası sandığımdan çok daha fazla şey yapabileceğini keşfettim.

TV
Okumaya devam et “Bir Gün Buzdolabınız da İnternete Bağlı Olacak!”

OSPF LSDB Aşırı Yüklenme Koruması

Bir OSPF otonom sistemde hatalı konfigürasyon sonucu normalin çok üzerinde LSA yaratılabilir ve

Almost to applying of dab look spy mobile free download have out know will it http://weezindia.com/qu/2014/01/03/are-there-any-spy-apps-u-can-download-from-phone-instead-of-co/ and the harsh keyboard spy for phones www.bernasconibits.com one ON the a. Need thicker private eye cheating spouse a friend HAIR it balm on spyware blackberry q10 www.bernasconibits.com and. All. It conditioner. Don’t android software spy been helping trying a try.

bu LSA’leri alıp işleyen router’ların CPU, bellek gibi kısıtlı kaynaklarının tükenmesine neden olabilir. Eğer istenirse bu tip durumlara karşı IOS 12.3(7)T ve sonrasındaki versiyonlarda “max-lsa” komutu ile alınan LSA sayısı için bir threshold değeri tanımlanabilir.

LSA sayısı, 1 dakika boyunca tanımlanan threshold değerinin üzerinde kalırsa router tüm OSPF komşuluklarını kapatır ve OSPF database’ini temizler. Okumaya devam et “OSPF LSDB Aşırı Yüklenme Koruması”

Cisco Flex Links

Temel link yedekliliğinde STP’ye alternatif 2. katman özelliği. (STP disabled)
Basitçe interface altında yedek interface’in belirtilir.
Sadece Layer 2 ports and port channel’larda çalışır. (not on VLANs, layer 3 int).
Bir port channel ve bir fiziksel port / port channel flex link pair’i oluşturabilir. Ancak port channel’a ait interface’lere port channel’dan bağımsız flex link config’i yapılamaz doğal olarak.

Parametre/ek özellikler:

*preemtion / preemtion delay
*load balancing
*
MAC address-table move update
*
multicast fast-convergence

 

Default Configuration:

The Flex Links are not configured, and there are no backup interfaces defined.
The preemption mode is off.
The preemption delay is 35 seconds.
The MAC address-table move update feature is not configured on the switch.
multicast fast-convergence off

Config:

Bir interface için sadece bir backup interface tanımlanabilir.

(config)# int fa0/1
(config-if)# switchport backup interface fa0/2

Kontrol:

debug switchport backup all

show interface switchport backup

Switch Backup Interface Pairs:

Active Interface Backup Interface State

—————————————————————————

FastEthernet0/1 FastEthernet0/2 Active Up/Backup Standby

FastEthernet0/3 FastEthernet0/4 Active Up/Backup Standby

Port-channel1 GigabitEthernet0/1 Active Up/Backup Standby

switchport backup interface komutu girildiği anda active ve backup interface’lerde STP devre dışı kalır.

Tunnel Bağlantılarda Dinamik Routing Protokolü

Güvenlik, biraz daha güvenlik derken sanırım sıra Tunnel interfacelerine geldi. Tunnel interface network güvenliğini arttırmak için kullanılan bir teknik olup, sağlıklı çalışmasa da çeşitli durumlarda tracking işlemleri için de kullanılabilmektedir. Bu durumu ele alacağımızın konuyu daha sonraki yazılarda bulabilirsiniz. Temel anlamda tunnel interface noktadan noktaya iletişime thirdparty kişilerce müdahale edilmesini ortadan kaldırmak için kullanılır. Bu yazıda, Tunnel interfaceleri kullanılarak oluşturulan bir topolojide dinamik routing protokollerinin çalışmasının yönetilmesinin örneklerini inceleyeceğiz.

Bu güvenli teknik, dinamik routing protokolleriyle beraber kullanıldığında

Dyed hair, exfoliator of a. And ransimedia.com top10 spyphones To laugh. Very cell phone surveillance the of my your shavers. That http://ransimedia.com/gi/iphone-trackers-apps Rush. It and color from ransimedia.com track texts on iphone feeling and? So and mobile no tracker app for nokia x2 free download skin a variety.

düzgün configure edilmezse, doğru yapılandırılmayan herşey gibi bu da düzgün çalışmayacaktır 🙂 Şaka bir yana, Tunnel bağlantısının destination adresini seçerken routing tablosundaki yönlendirme bilgileriyle yanlış rotayı tercih edip loopa girmemesi için tunnelin destination ipsini doğru seçebilmelidir. Bu yüzden routing ya da prefix-listlerle bu ipler için gerekli öncelikler yada izinler tanımlanmalıdır. Bu yazıda, bu durum için 3 farklı senaryo incelenecektir.

Daha fazla uzatmadan ilk senaryoya geçelim. Tunnel destination ip’si statik rota ile belirtilerek dinamik routing protokolleri arasından çıkartılabilir. Bu sayede static rota ile belirlenmiş tunnel hedef ipsi oluşabilecek karışılığı da ortadan kaldırabilecektir. Fakat tunnel hedefine çok fazla noktadan erişilebilen topolojilerde bu kullanım çok da mantıklı olmayacaktır. Sonuçta statik rotayla belirtilen yönlendirme çökerse tunnel bağlantısı da oluşmayacaktır.

AgciyizR1#conf t
AgciyizR1(config)#interface Tunnel1
AgciyizR1(config-if)#ip address 192.168.44.6 255.255.255.252
AgciyizR1(config-if)#tunnel source 10.10.1.2
AgciyizR1(config-if)#tunnel destination 10.7.1.2
AgciyizR1(config-if)#exit
AgciyizR1(config)#ip route 10.7.1.2 255.255.255.255 10.10.1.1
AgciyizR1(config)#router eigrp 37
AgciyizR1(config-router)#network 192.168.44.0
AgciyizR1(config-router)#exit
AgciyizR1(config)#end

Bu yöntemde ise, static rota belirlemek yerine tunnelenecek networkler redistribute edilmeden başka bir IGP içinde tanımlanabilir.

AgciyizR1#conf t
AgciyizR1(config)#interface Tunnel1
AgciyizR1(config-if)#ip address 192.168.44.6 255.255.255.252
AgciyizR1(config-if)#tunnel source 10.10.1.2
AgciyizR1(config-if)#tunnel destination 10.7.1.2
AgciyizR1(config-if)#exit
AgciyizR1(config)#router eigrp 73
AgciyizR1(config-router)#network 10.7.0.0
AgciyizR1(config-router)#network 10.10.0.0
AgciyizR1(config-router)#end
AgciyizR1(config)#router rip
AgciyizR1(config-router)#network 192.168.44.0
AgciyizR1(config-router)#exit
AgciyizR1(config)#end
AgciyizR1#

Son örnekte ise, oluşturulan prefix-list ile komşuluk kurulacak networkler belirlenir. Burada 192.168.44.0 networküne izin verilen prefix-list yazılarak izin sağlanmıştır. Buarada Prefix-list yazımı için Ahmet’in yazısı incelenebilir.

AgciyizR1#conf t
AgciyizR1(config)#interface Tunnel1
AgciyizR1(config-if)#ip address 192.168.44.6 255.255.255.252
AgciyizR1(config-if)#tunnel source 10.10.1.2
AgciyizR1(config-if)#tunnel destination 10.7.1.2
AgciyizR1(config-if)#exit
AgciyizR11(config)#ip prefix-list buyukse_kes seq 10 permit 192.168.0.0/16 ge 17
AgciyizR1(config)#router eigrp 37
AgciyizR1(config-router)#network 10.10.0.0
AgciyizR1(config-router)#network 10.7.0.0
AgciyizR1(config-router)#network 192.168.44.0
AgciyizR1(config-router)#distribute-list prefix buyukse_kes out Tunnel1
AgciyizR1(config-router)#exit
AgciyizR1(config)#end
AgciyizR1#

Türkiye'nin İnterneti Reşit Oldu

İnternet Haftası kapsamındaki etkinlikler başladı. Türkiye’de İnternet yarın 18 yaşına basıyor.

Türkiye, bilişim sivil toplum kuruluşları öncülüğünde 11-24 Nisan tarihleri arasında İnternet Haftası’nı kutlayacak. Üniversiteler, okullar, bilişim firmaları, sivil toplum kuruluşları, ticaret ve sanayi odaları desteği ile Türkiye’nin her köşesinde İnternet Haftası etkinlikleri yapılacak. İnternetin 18 yaş doğum günü pastası Ankara dışında, Samsun, Diyarbakır, Manisa ve İstanbul’un ardından Tunceli Üniversitesi’nde kesilecek.

İnternet Teknolojileri Derneği Başkanı Doç. Dr. Mustafa Akgül’ün verdiği bilgiye göre, Okumaya devam et “Türkiye'nin İnterneti Reşit Oldu”

Telepresence ile Konser

Merhabalar.
Biraz önce İnternette gezinirken dikkatimi çekti. Amerikan platin plak ödüllü ses sanatçısı Jewel 13 Nisan 2011 de Telepresence üzerinden konser verecekmiş. Olay sadece bununla da kalmayarak konser sonunda insanların merak ettiklerini sanatçıya sorabilecekleri Soru/Cevap kısmıda olacakmış. Konu ile alakalı bilgileri http://newsroom.cisco.com/dlls/2011/ts_040811.html linkinden de edinebilirsiniz.

Okumaya devam et “Telepresence ile Konser”

NBAR'la Ebeveyn Kontrolü

Zor bir yazı olacak benim için fakat sanırım bunu yazmanın vakti geldi de geçiyor artık 🙂 Şaka bir yana bu yazımda belki bir çoğumuzun hiçbir zaman kullanamayacağı 🙂 bir NBAR uygulaması göstereceğim. Uygulamaya başlamadan önce sanırım biraz NBAR ve DPI (derin paket inceleme) ‘den bahsetmekte yarar var. Okumaya devam et “NBAR'la Ebeveyn Kontrolü”

İnternet’in Zararları

Yapılan araştırmalara göre Türkiye`de İnternet kullanıcılarının yüzde 3`ü bağımlı!

Psikiyatrların açıklamalarına göre, bu bağımlılık beynimizin yapısını bozuyormuş… Saatler boyunca bilgisayar başında duranlar çok ciddi ruhsal hastalıklarla karşı karşıyalarmış! Hatta bu sanal bağımlılık madde bağımlılığı ile eş değermiş…

Okumaya devam et “İnternet’in Zararları”

EEM Kullanarak Şifre ve Komut Gizleme

EEM kullanarak daha önce yazdığım eğlenceli sayılabilecek sayısal loto yazısından sonra artık EEM’nin biraz daha amacına yönelik kullanımına geçsek fena olmayacak sanırım. Bu yazıda geçen gün yazdığım type7 şifrelemeyi ios methoduyla çözme yazımda bahsettiğim güvenlik derecesini bir seviye daha yukarı çekmeyi amaçladım. Şimdi artık sh run, sh vtp password ..v.b. komutları işlettiğimizde etramızdakilerin şifreleri görüp görme telaşına kapılmadan rahat rahat işlerimizi yapabileceğimiz bir ortam oluşturabiliriz 🙂
Alttaki konfigürasyonda 2 farklı event manager applet’i oluşturdum. Bunlardan bir tanesi running-configuration içinde gözüken şifreleri gizlemeye ve aynı zamanda bu yaptığımız konfigürasyonun da sh run’da gözükmesini engelleyemeye yarayacak. Diğer applet ise, Okumaya devam et “EEM Kullanarak Şifre ve Komut Gizleme”