3G konfigürasyon

Bir önceki yazımda Cisco routerlarda 3G kartını tanıtmıştım. Şimdi ise gsm konfigürasyonunu oluşturacağız.

İlk önce servis sağlayıcımızdan (Turkcell, Vodafone ya da Avea ) kullanıcı adı, şifre ve access-point ismini almamız gerekiyor. Bunları aldıktan sonra router’a ilk konfigürasyonu girebiliriz.

Router# cellular 0 gsm profile create 1 <ap ismi> <pap/chap> <kullanıcı adı> <şifre>

Buradaki 1, oluşturduğumuz profilin numarası. Birden fazla profil yaratılabilir. Ancak bu profil numarası önemli, daha sonra aşağıdaki komutta kullanacağız.

Router#chat-script gsm "" "ATDT*98*1#" TIMEOUT 30 CONNECT

chat-script komutu modem üzerinden arama yapılmasını sağlar. ATDT modem bağlantı komutudur ve açılımı Attention Dial Tone’dur. 98 IP servisleri kullanmasını gösteren bir dizidir. Bazen 99’da kullanılır. 99 ise paket servislerinin kullanılmasını gösterir.

Daha sonra cellular interface’in bağlı olduğu line konfigüre edilir. 3G, üçüncüsünü kullanır.

line 3
 exec-timeout 0 0
 script dialer gsm
 login
 modem InOut

Son olarak cellular interface konfigüre edilir.

interface Cellular 0
 ip address negotiated
 encapsulation ppp
 dialer in-band
 dialer string gsm
 dialer-group 1
 async mode interactive
 ppp chap hostname onur
 ppp chap password cicek
 ppp ipcp dns request

Konfigürasyon böyle. Tabi yönlendirme, güvenlik aşamalarıyla örnek konfigürasyon şöyle oluyor:

multilink bundle-name authenticated

chat-script gsm "" "ATDT*99#" TIMEOUT 60 "CONNECT"

!

interface Cellular0
 ip address negotiated
 dialer in-band
 dialer-group 5
 async mode interactive
 ppp chap hostname onur
 ppp chap password cicek
 ppp ipcp dns request
!

ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Cellular0
no ip http server

no ip http secure-server
!

ip nat inside source list 101 interface cellular0 overload

!

access-list 101 permit ip any any

dialer-list 5 protocol ip permit
!
line 3
script dialer gsm
modem InOut
no exec
transport input all
transport output all
rxspeed 7200000
txspeed 2000000
escape-character 0
no ip tcp input-coalesce-threshold
callback forced-wait 0
callback nodsr-wait 0
stopbits 1
speed 115000

Eğer 3G hattı yedek olarak kullanacaksak track ve backup interface komutlarını kullanmamız gerekiyor.

interface ATM 0
 no ip address
 ip virtual-reassembly
 load-interval 30
 no atm ilmi-keepalive
!
interface ATM 0.1 point-to-point
 backup interface Cellular0
 ip nat outside
 ip virtual-reassembly
 pvc 0/35
  pppoe-client dial-pool-number 2
 !
interface Cellular0
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer in-band
 dialer string gsm
 dialer-group 1
 async mode interactive
 ppp chap hostname onur
 ppp chap password cicek
 ppp ipcp dns request
!
interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 load-interval 30
 dialer-group 2
 ppp authentication chap callin
 ppp chap hostname onur
 ppp chap password 0 cicek
 ppp ipcp dns request
 !
ip local policy route-map track-primary-if
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0 track 234
ip route 0.0.0.0 0.0.0.0 Cellular0 track 254
no ip http server
no ip http secure-server
!
ip nat inside source route-map 3g-yedek interface Cellular0 overload
ip nat inside source route-map bim interface Dialer0 overload
!
access-list 1 permit any
access-list 3 permit any
access-list 101 permit ip 10.1.1.0 0.0.0.255 any
access-list 102 permit icmp any host 1.1.1.1
dialer-list 1 protocol ip list 1
dialer-list 2 protocol ip permit
!
route-map track-primary-if permit 10
 match ip address 102
 set interface Dialer0
!
route-map bim permit 10
 match ip address 101
 match interface Dialer0
!
route-map 3g-yedek permit 10
 match ip address 101
 match interface Cellular0
!

“3G konfigürasyon” için bir cevap

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir