6500 Serisi Switchlerde Aggregate Policing

Cisco 6500 serisi anahtarlar iki çeşit aggregate policer (toplam sınırlandırıcı) destekler. Bunlar per-interface (arayüz bazlı) ve named(isimlendirilmiş) aggregate policer’lardır. Per-interface aggregate policer uygulandığı her arayüz için giriş yönünde ayrı ayrı sınırlandırma yapar. Per-interface sınırlandırıcı policy-map yapılandırması ile tanımlanır. İsimlendirilmiş aggregate policer ise uygulandığı tüm arayüzlerdeki trafiğin toplamına sınırlandırma getirir. İsimlendirilmiş aggregate policer Cisco yönlendiriciler tarafından desteklenmemektedir.

Per-interface aggregate policer ile toplam bant genişliği sınırının belirlenmesi aşağıdaki şekilde yapılır. Bu örnekte gigabit 2/1 arayüzüne gelen trafiğin toplam 60Mb ile sınırlanmasını sağlayan yapılandırma gösterilmiştir.

6500(config)# mls qos
6500(config)# access-list 160 permit ip any 10.0.0.0 0.0.0.255
6500(config)# class-map 60Mb_Sinifi
6500(config-cmap)# match access-group 160
6500(config-cmap)# exit
6500(config)# policy-map 60Mb_toplam
6500(config-pmap)# class 60Mb_Sinifi
6500(config-pmap-c)# police 60000000
6500(config-pmap-c)# exit
6500(config-pmap)# exit

6500(config)# int gi2/1
6500(config-if)# service-policy input 60Mb_toplam

İsimlendirilmiş aggregate policer ile toplam bant genişliği sınırının belirlenmesi ise şu şekilde yapılır. Bu örnekte gi2/1 arayüzüne gelen tcp 445 hedefli trafiğin toplam 10Mb ile sınırlanmasını sağlayan yapılandırma gösterilmiştir. Tanımlanan named aggregate policer farklı policy-map’lerde de kullanılabilir. Bu durumda named aggregate policer’da tanımlanan bant genişliği uygulandığı policy-map’ler tarafından ortak olarak paylaşılır.

! QoS aktif hale getirildi.
6500(config)# mls qos
! İsimlendirilmiş aggregate policer tanımlandı.
6500(config)# mls qos aggregate-policer smb_10Mb 10000000 312000 312000 conform-action transmit exceed-action drop
6500(config)# access-list 110 permit tcp any any eq 445
6500(config)# class-map smb
6500(config-cmap)# match access-group 110
6500(config-cmap)# exit
6500(config)# policy-map 10Mb
6500(config-pmap)# class smb
6500(config-pmap-c)# police aggregate smb_10Mb
6500(config-pmap-c)# exit
6500(config-pmap)# exit

6500(config)# int gi2/1
6500(config-if)# service-policy input 10Mb
6500(config)# int gi2/2
6500(config-if)# service-policy input 10Mb
Not: Bu konfigurasyon ile tanımlanan class-map ile eşleşen trafik için Gigabit 2/1 ve Gigabit 2/2 interface’lerine girebilecek bant genişliği toplam 10Mb ile sınırlandırılmıştır.

Gökhan AKIN – Sınmaz KETENCİ

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir