Cisco IOS CLI ipuçları

Merhabalar, bu yazıda Cisco IOS CLI kullanımında işimize yarayacak birtakım ipuçları ve kısayollardan bahsedeceğim, bu sayede sorunları tespit etmede ve çözmede daha hızlı olacağız, umarım faydalı olur 🙂

Öncelikle komut yazarken pratiktlik sağlayan klavye kısayolları için, Oğul’un yazmış olduğu  Cisco IOS CLI’da klavye kısayolları yazısına bir bakın derim..

 * “Show” komutu çıktılarını ayarlama

Muhtemelen çoğu CLI ile çalışan networkçü  “|” sembolünü görmüştür. Bu sembol ile “show” komutunu bir nevi görmek istediğimiz/istemediğimiz bilgi için filtrelemiş oluyoruz. En çok kullanılan parametreleri  begin, section, include ve exclude olmak üzere;

– Begin girdiğimiz kelimeye denk gelene kadar tüm çıktıyı filtreler;

AgciyizRouter# show run | begin ospf
ip ospf priority 5


!
end

– Section girdiğimiz kelimeye ait konfigurasyonu gösterir;

AgciyizRouter# show run | section int
interface FastEthernet0/0
no ip address
shutdown
speed auto
duplex auto
interface FastEthernet0/1
no ip address
shutdown
speed auto
duplex auto

 Exclude girdiğimiz kelimenin olduğu satırları filtreler;

AgciyizRouter# show run | exclude !
Building configuration…

Current configuration : 754 bytes
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname AgciyizRouter
boot-start-marker
boot-end-marker
no aaa new-model

end

– Include sadece girdiğimiz kelimeye ait satırları gösterir, geri kalanı filtreler, bu parametrede regular expression(düzenli ifade) kullanarak daha detaylı arama yapmamızda mümkündür, ancak ayrıntılı bir konu olduğu için derin bir açıklama yapmadım, sadece birkaç örnek olarak ip adresine sahip interfacelerin çıktısını almak istersek

AgciyizRouter# show run | inc ^interface | ip address
interface FastEthernet0
ip address 192.168.0.1 255.255.255.0
interface FastEthernet1
ip address 192.168.1.1 255.255.255.0
ip address 10.1.1.1 255.255.255.0 secondary

Bir başka örnek olarak Access-list girilmiş interfaceleri görmek istersek;

AgciyizRouter# sh ip int | inc line protocol | access list is [^ ]+$
FastEthernet0 is up, line protocol is up
Inbound access list is deny10
FastEthernet1 is up, line protocol is up
Inbound access list is 11
FastEthernet2 is up, line protocol is up

 
Bu kısımdaysa daha çok konfigurasyonlarda kullanacağımız birkaç ipucundan bahsedeceğim.

* Konsol bağlantılarda veya telenet/ssh bağlantılarda timeout süresini kapatmak;
    “console/ VTY” line altında

AgciyizRouter(config)#line con 0

AgciyizRouter(config-line)#exec-timeout 0 0                    !  0-minutes 0-seconds

* Sistem mesajlarıın konfigursayon anında engellmesini önlemek için;

AgciyizRouter(config)#line con 0
AgciyizRouter(config-line)#logging synchronous

* Bir interface’i yada interface aralığını varsayılan konfigurasyonuna geri almak için;

AgciyizRouter(config)#default interface fa0/0
Building configuration…

* — Translating “kelime”…domain server (4.2.2.2) — DNS çözümlemesi artık bekletmesin 🙂

AgciyizRouter(config)#no ip domain-lookup

* “alias” komutuyla klavyeden kazanma;
bizi uzun uzun komut yazmaktan kurtaran “alias” komutunu kullanacağımız birkaç örnek vereceğim, ilki “show process cpu” yu kısaltmak; bunun için tüm komut yerine “showproc” yazarak bu işi hallediyoruz, hatta 0 ortalama gösteren çıktıları yeni öğrendiğimiz “|” ile filtreliyoruz 🙂

AgciyizRouter(config)#alias exec showproc sh proc cpu sorted | ex 0.00%__0.00%__0.00%

ikinci olarak CLI üstünden ssh çekmeyi kolay hale getirmek için;

AgciyizRouter(config)#alias exec es ssh -l admin (siz isteğinize göre bir kelime girebilirsiniz)

son olarak ufak ama tricky olan global-config modda “show” komutu için sinir bozucu “do” kullanma zorunluluğunu ortadan kaldırmak için;

AgciyizRouter(config)#alias configure show do show

* hayat kurtarıcı “reload in 5” 🙂
uzaktaki bir ağ cihazını konfigure ederken herhangi bir hataya karşı cihaza erişimin kaybolması, tabiri caizse patlaması ihtimaline  karşı konfigurasyona başlamadan önce bu komutu girerek cihazı 5 dakika sonra startup-config’den başlatıp hatalı kısmı iptal edip tekrar hayata döndürmemiz mümkün, (hızına güvenen 1 dakika girebilir 🙂 )

Router#reload in 5
Reload scheduled for 16:31:15 EDT Fri Jun 8 2010 (in 5 minutes) by admin on vty0 (198.19.8.98)
Reload reason: Reload Command
Proceed with reload? [confirm]

Bir yazının daha sonuna geldik, bu yazıda elimden geldiğince CLI üstünde mesai harcayanlar   için faydalı olacağını düşündüğüm birtakım ipuçları yazdım, tabiki bunlar arttırılabilir, kişiye göre modifiye edilebilir, yani herşey sizin elinizde. Bir sonraki yazıda görüşmek üzere sağlıcakla kalın..

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir