OSPF Network Çeşitleri -I-

Ospf’te routing info trafiğinin azaltılması için hiyerarşik bir yapı olan arealar oluşturulmuştur. Area içerisinde de çok fazla OSPF multicast paketleri olabileceği için bu paketleri azaltmak adına DR ve BDR seçimi yapılır. Paketlerin tüm routerlar yerine sadece Dr ve BDR gönderimi sağlanır, DR ve BDR da multicast ile diğer routerlara bildirir. BGP’deki route reflectora benzer yapıdır. Ospf farklı network modellerinde çalışabilen bir protokoldür. Bu yazıda Ospf’in Broadcast ve Point-to-Point networklerdeki davranışı ve konfigürasyonu ele alınacaktır.


BROADCAST

• Full yada parçalı mesh topoloji
• Tek subnet
• Hello timer 10 sn
• Otomatik komşuluk kurulur.
• DR&BDR seçilir.

R1#sh run | b router ospf 1
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0

R1#sh run int f0/0
Building configuration…

Current configuration : 123 bytes
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip ospf network broadcast
end

R1#sh ip ospf int f0/0
FastEthernet0/0 is up, line protocol is up
Internet Address 192.168.1.1/24, Area 0
Process ID 1, Router ID 192.168.1.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DROTHER, Priority 1
Designated Router (ID) 192.168.1.3, Interface address 192.168.1.3
Backup Designated router (ID) 192.168.1.2, Interface address 192.168.1.2
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:07
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 192.168.1.2 (Backup Designated Router)
Adjacent with neighbor 192.168.1.3 (Designated Router)
Suppress hello for 0 neighbor(s)

R2#sh run | b router ospf 1
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0

R2#sh run int f0/0
Building configuration…

Current configuration : 96 bytes
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
end

R2#sh ip ospf int f0/0
FastEthernet0/0 is up, line protocol is up
Internet Address 192.168.1.2/24, Area 0
Process ID 1, Router ID 192.168.1.2, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 192.168.1.3, Interface address 192.168.1.3
Backup Designated router (ID) 192.168.1.2, Interface address 192.168.1.2
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:05
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 1
Last flood scan time is 4 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 192.168.1.1
Adjacent with neighbor 192.168.1.3 (Designated Router)
Suppress hello for 0 neighbor(s)
R3#sh run | b router ospf 1
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0

R3#sh run int f0/0
Building configuration…

Current configuration : 96 bytes
!
interface FastEthernet0/0
ip address 192.168.1.3 255.255.255.0
end

R3#sh ip ospf int f0/0
FastEthernet0/0 is up, line protocol is up
Internet Address 192.168.1.3/24, Area 0
Process ID 1, Router ID 192.168.1.3, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.1.3, Interface address 192.168.1.3
Backup Designated router (ID) 192.168.1.2, Interface address 192.168.1.2
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:08
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 2
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 192.168.1.1
Adjacent with neighbor 192.168.1.2 (Backup Designated Router)
Suppress hello for 0 neighbor(s)

Peki topoloji LAN değil de frame-relay olursa ne olur? Frame-relay’de de full mesh bir topoloji oluşturulabilir. Aşağıda tüm routerların birbirlei ile bağlantılı olduğunun testi görülmektedir.

R1#sh run int s1/0
Building configuration…

Current configuration : 215 bytes
!
interface Serial1/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.2 102
frame-relay map ip 192.168.1.3 103
end
R2#sh run int s1/0
Building configuration…

Current configuration : 215 bytes
!
interface Serial1/0
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.1 201
frame-relay map ip 192.168.1.3 203
end
R3#sh run int s1/0
Building configuration…

Current configuration : 215 bytes
!
interface Serial1/0
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.1 301
frame-relay map ip 192.168.1.2 302
end
R1#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/20 ms
R1#ping 192.168.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms
R2#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
R2#ping 192.168.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/11/24 ms
R3#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/12 ms
R3#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/6/8 ms
Bağlantı test edilmiştir ve tüm interfacelerde broadcast komutu yürütülmektedir.

R1#sh ip ospf nei

Ospf komşuluğu görülmemektedir. Process yeniden başladığında da tablo oluşmamaktadır.

R1#clear ip ospf 1 process
Reset OSPF process? [no]: y
R1#sh ip ospf nei

Debug açtığımızda sorun görülmektedir. R1 multicast kullanmaktadır. Frame-relay’de paket geçmediğini kontrol ederlim

R1#debug ip ospf hello
OSPF hello events debugging is on
Reset OSPF process? [no]: y
R1#
*Mar 1 00:17:15.135: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.1.1
*Mar 1 00:17:25.135: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.1.1
*Mar 1 00:17:35.135: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.1.1
R1#sh frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

Active Inactive Deleted Static
Local 2 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 45 output pkts 45 in bytes 4116
out bytes 4104 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:30:30, last time pvc status changed 00:28:50

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 57 output pkts 45 in bytes 5248
out bytes 4144 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:30:31, last time pvc status changed 00:28:51

R1#sh frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

Active Inactive Deleted Static
Local 2 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 45 output pkts 45 in bytes 4116
out bytes 4104 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:31:23, last time pvc status changed 00:29:44

DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 57 output pkts 45 in bytes 5248
out bytes 4144 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:31:26, last time pvc status changed 00:29:46

OSPF multicast ile haberleşmeye çalıştığı fakat paket geçmediği görülmektedir. Unutulmamalıdır ki Frame Relay NBMA networktür. Bu yüzden Frame-Relay link doğası gereği Broadcast/Multicast paketlere izin vermez. Aşağıdaki komut ile non-broadcast çevrede, broadcastler belirtilen ip adresine gönderilir.

frame-relay map ip broadcast

R1(config)#int s1/0
R1(config-if)#do sh run int s1/0
Building configuration…

Current configuration : 215 bytes
!
interface Serial1/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.2 102
frame-relay map ip 192.168.1.3 103
end

R1(config-if)#frame-relay map ip 192.168.1.2 102 broadcast
R1(config-if)# frame-relay map ip 192.168.1.3 103 broadcast
R1(config-if)#
R1(config-if)#
*Mar 1 00:45:46.727: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.2 on Serial1/0 from LOADING to FULL, Loading Done
*Mar 1 00:45:46.743: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.3 on Serial1/0 from LOADING to FULL, Loading Done

Debug ile çalıştığı görülmektedir.

*Mar 1 00:44:57.927: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.1.2
*Mar 1 00:45:07.927: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.1.2
*Mar 1 00:45:17.927: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.1.2
*Mar 1 00:45:27.931: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.1.2
*Mar 1 00:45:37.931: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.1.2
*Mar 1 00:45:46.107: OSPF: Rcv hello from 192.168.1.1 area 0 from Serial1/0 192.168.1.1
*Mar 1 00:45:46.111: OSPF: Send immediate hello to nbr 192.168.1.1, src address 192.168.1.1, on Serial1/0
*Mar 1 00:45:46.115: OSPF: Send hello to 192.168.1.1 area 0 on Serial1/0 from 192.168.1.2
*Mar 1 00:45:46.119: OSPF: End of hello processing
*Mar 1 00:45:46.135: OSPF: Rcv hello from 192.168.1.1 area 0 from Serial1/0 192.168.1.1
*Mar 1 00:45:46.139: OSPF: End of hello processing
*Mar 1 00:45:46.171: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.1 on Serial1/0 from LOADING to FULL, Loading Done

Tüm routerlarda broadcast komutunun çalıştırılması gerekmektedir.


POINT-TO-POINT

Routerlar noktadan noktaya bağlıdır. Updateleri birbirleri arasında gönderdikleri için DR ve BDR’a gerek yoktur. Her router hello paketlerini 224.0.0.5 multicast adresini kullanarak gönderirler.. OSPF hello ve dead timerlar sırasıyla 10 ve 40’tır. Point-to-Point için Ospf kullanımı Cisco tarafından geliştirilmiştir
• Partial-mesh veya star topolojide subinterfaceler ile kullanılır.
• Her subinterface için farklı subnet kullanılır.
• Hello timer 10sn’dir
• Otomatik komşuluk kurulur, DR&BDR seçilmez.

R1#sh run | b 1/0
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.102 point-to-point
ip address 192.168.102.1 255.255.255.252
ip ospf network point-to-point
snmp trap link-status
frame-relay interface-dlci 102
!
interface Serial1/0.103 point-to-point
ip address 192.168.103.1 255.255.255.252
ip ospf network point-to-point
snmp trap link-status
frame-relay interface-dlci 103

R1#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 0 FULL/ – 00:00:34 192.168.103.2 Serial1/0.103
2.2.2.2 0 FULL/ – 00:00:32 192.168.102.2 Serial1/0.102

R1#sh ip ospf int s1/0.102
Serial1/0.102 is up, line protocol is up
Internet Address 192.168.102.1/30, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)

R1#sh ip ospf int s1/0.103
Serial1/0.103 is up, line protocol is up
Internet Address 192.168.103.1/30, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:04
Supports Link-local Signaling (LLS)
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 3.3.3.3
Suppress hello for 0 neighbor(s)

R2#debug ip ospf hello
OSPF hello events debugging is on
R2#
*Mar 1 04:48:33.414: OSPF: Rcv hello from 1.1.1.1 area 0 from Serial1/0.201 192.168.102.1
*Mar 1 04:48:33.418: OSPF: End of hello processing
*Mar 1 04:48:37.458: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0.201 from 192.168.102.2
*Mar 1 04:48:37.462: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0.203 from 192.168.203.1
*Mar 1 04:48:41.002: OSPF: Rcv hello from 3.3.3.3 area 0 from Serial1/0.203 192.168.203.2
*Mar 1 04:48:41.002: OSPF: End of hello processing
R2#sh run | b 1/0
interface Serial1/0
no ip address
encapsulation frame-relay
!
interface Serial1/0.201 point-to-point
ip address 192.168.102.2 255.255.255.252
ip ospf network point-to-point
snmp trap link-status
frame-relay interface-dlci 201
!
interface Serial1/0.203 point-to-point
ip address 192.168.203.1 255.255.255.252
ip ospf network point-to-point
snmp trap link-status
frame-relay interface-dlci 203

R2#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 0 FULL/ – 00:00:33 192.168.203.2 Serial1/0.203
1.1.1.1 0 FULL/ – 00:00:35 192.168.102.1 Serial1/0.201

R2#sh ip ospf int s1/0.201
Serial1/0.201 is up, line protocol is up
Internet Address 192.168.102.2/30, Area 0
Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:09
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 1.1.1.1
Suppress hello for 0 neighbor(s)

R2#sh ip ospf int s1/0.203
Serial1/0.203 is up, line protocol is up
Internet Address 192.168.203.1/30, Area 0
Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:07
Supports Link-local Signaling (LLS)
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 3.3.3.3
Suppress hello for 0 neighbor(s)
R3#sh run | b 1/0
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.301 point-to-point
ip address 192.168.103.2 255.255.255.252
ip ospf network point-to-point
snmp trap link-status
frame-relay interface-dlci 301
!
interface Serial1/0.302 point-to-point
ip address 192.168.203.2 255.255.255.252
ip ospf network point-to-point
snmp trap link-status
frame-relay interface-dlci 302

R3#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:00:39 192.168.203.1 Serial1/0.302
1.1.1.1 0 FULL/ – 00:00:36 192.168.103.1 Serial1/0.301

R3#sh ip ospf int s1/0.301
Serial1/0.301 is up, line protocol is up
Internet Address 192.168.103.2/30, Area 0
Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 1.1.1.1
Suppress hello for 0 neighbor(s)

R3#sh ip ospf int s1/0.302
Serial1/0.302 is up, line protocol is up
Internet Address 192.168.203.2/30, Area 0
Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:00
Supports Link-local Signaling (LLS)
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)

“OSPF Network Çeşitleri -I-” için bir cevap

  1. Merhaba
    Makale için teşekkürler yalnız yukarıda
    BROADCAST Network Type için DR ve BDR seçilmez yazmışsınız
    Fakat OSPF BROADCAST Type Networkde bu seçim otomatik
    olarak yapılır. Nitekim sh ip ospf int fa0/0 altında bu görünüyor
    Saygılar

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir