OSPF Network Çeşitleri -II-

POINT-TO-MULTIPOINT

• Parçalı mesh veya star topolojilerde kullanılır
• Tek subnet kullanılır
• Hello timer 30 sn’dir
• Otomatik komşuluk kurulur, DR & BDR seçilmez.



R1#sh run int s1/0
Building configuration…

Current configuration : 273 bytes
!
interface Serial1/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 192.168.1.2 102 broadcast
frame-relay map ip 192.168.1.3 103 broadcast

no frame-relay inverse-arp
end

R1#sh run | s router ospf
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0

R1#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:01:36 192.168.1.2 Serial1/0
3.3.3.3 0 FULL/ – 00:01:32 192.168.1.3 Serial1/0

R1#debug ip ospf hello
OSPF hello events debugging is on
R1#
*Mar 1 02:50:50.839: OSPF: Rcv hello from 3.3.3.3 area 0 from Serial1/0 192.168.1.3
*Mar 1 02:50:50.843: OSPF: End of hello processing
*Mar 1 02:50:54.995: OSPF: Rcv hello from 2.2.2.2 area 0 from Serial1/0 192.168.1.2
*Mar 1 02:50:54.995: OSPF: End of hello processing
*Mar 1 02:50:57.883: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0 from 192.168.1.1

R1#sh ip ospf int s1/0
Serial1/0 is up, line protocol is up
Internet Address 192.168.1.1/24, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_MULTIPOINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:12
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 2.2.2.2
Adjacent with neighbor 3.3.3.3
R2#sh run int s1/0
Building configuration…

Current configuration : 273 bytes
!

interface Serial1/0
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 192.168.1.1 201 broadcast
frame-relay map ip 192.168.1.3 203 broadcast

no frame-relay inverse-arp
end

R2#sh run | s router ospf
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
R2#sh ip ospf nei

Neighbor ID           Pri State                    Dead Time               Address              Interface
1.1.1.1 0                    FULL/ –                   00:01:59                  192.168.1.1        Serial1/0
3.3.3.3 0                   FULL/ –                   00:01:53                 192.168.1.3         Serial1/0

R3#sh run int s1/0
Building configuration…

Current configuration : 273 bytes
!
interface Serial1/0
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
serial restart-delay 0
frame-relay map ip 192.168.1.1 301 broadcast
frame-relay map ip 192.168.1.2 302 broadcast

no frame-relay inverse-arp
end

R3#sh run | s router ospf
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
R3#sh ip ospf nei

Neighbor ID              Pri State              Dead Time           Address                Interface
2.2.2.2 0                      FULL/ –               00:01:32           192.168.1.2          Serial1/0
1.1.1.1 0                       FULL/ –                00:01:35           192.168.1.1         Serial1/0

NON-BROADCAST MULTI ACCESS (NBMA)

• Full yada parçalı mesh topoloji
• Tek subnet
• Hello interval 30 sn
• Manuel komşuluk kurulur, DR &BDR seçilir.
OSPF non-broadcast komutu kullanılır.
R1#sh run int s1/0
Building configuration…

Current configuration : 219 bytes
!
interface Serial1/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network non-broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.2 102
frame-relay map ip 192.168.1.3 103
no frame-relay inverse-arp
end

R1#sh run | s router ospf
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
neighbor 192.168.1.2
neighbor 192.168.1.3

R1#sh ip ospf nei

Neighbor ID               Pri     State            Dead Time         Address           Interface
2.2.2.2 1                   FULL/DROTHER    00:01:39          192.168.1.2     Serial1/0
3.3.3.3 1                   FULL/DR                 00:01:38            192.168.1.3   Serial1/0

R2#sh run int s1/0
Building configuration…

Current configuration : 219 bytes
!
interface Serial1/0
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network non-broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.1 201
frame-relay map ip 192.168.1.3 203
no frame-relay inverse-arp
end

R2#sh run | s router ospf
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
neighbor 192.168.1.3
neighbor 192.168.1.1

R2#sh ip ospf nei

Neighbor ID            Pri    State              Dead Time                Address                 Interface
3.3.3.3 1                   FULL/DR               00:01:40                  192.168.1.3          Serial1/0
1.1.1.1 1                    FULL/BDR             00:01:40                  192.168.1.1          Serial1/0
R3#sh run int s1/0
Building configuration…

Current configuration : 219 bytes
!
interface Serial1/0
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network non-broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.1 301
frame-relay map ip 192.168.1.2 302
no frame-relay inverse-arp
end

R3#sh run | s router ospf
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
neighbor 192.168.1.1
neighbor 192.168.1.2

R3#sh ip ospf nei

Neighbor ID                   Pri    State              Dead Time               Address              Interface
1.1.1.1 1                        FULL/BDR                00:01:54              192.168.1.1         Serial1/0
2.2.2.2 1                     FULL/DROTHER     00:01:55              192.168.1.2        Serial1/0

R1#sh ip ospf int s1/0
Serial1/0 is up, line protocol is up
Internet Address 192.168.1.1/24, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 1.1.1.1, Interface address 192.168.1.1
Backup Designated router (ID) 2.2.2.2, Interface address 192.168.1.2
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:22
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 2.2.2.2 (Backup Designated Router)
Adjacent with neighbor 3.3.3.3
Suppress hello for 0 neighbor(s)

R1#debug ip ospf hello
OSPF hello events debugging is on
R1#
*Mar 1 01:43:40.059: OSPF: Send hello to 192.168.1.2 area 0 on Serial1/0 from 192.168.1.1
*Mar 1 01:43:40.063: OSPF: Send hello to 192.168.1.3 area 0 on Serial1/0 from 192.168.1.1
*Mar 1 01:43:41.411: OSPF: Rcv hello from 2.2.2.2 area 0 from Serial1/0 192.168.1.2
*Mar 1 01:43:41.415: OSPF: End of hello processing
*Mar 1 01:43:41.635: OSPF: Rcv hello from 3.3.3.3 area 0 from Serial1/0 192.168.1.3
*Mar 1 01:43:41.639: OSPF: End of hello processing

Broadcast networkten farklı paketlerin unicast olarak gönderilmesi ve komşuluğun otomatik olarak kurulamamasıdır.

POINT-TO-MULTIPOINT (NON-BROADCAST)

• Parçalı mesh ya da star topoloji kullanılır.
• Tek subnet kullanılır.
• Hello timer 30sn’dir
• Komşuluk otomatik kurulmaz. DR&BDR seçilmez.
• Cisco tarafından geliştirilmiş, OSPF network tipidir.

R1#sh run int s1/0
Building configuration…

Current configuration : 287 bytes
!
interface Serial1/0
ip address 192.168.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.2 102 broadcast
frame-relay map ip 192.168.1.3 103 broadcast

no frame-relay inverse-arp
end

R1#sh run | s router ospf
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
neighbor 192.168.1.3
neighbor 192.168.1.2

R1#sh ip ospf nei

Neighbor ID             Pri    State           Dead Time               Address                 Interface
3.3.3.3 0                 FULL/ –                 00:01:49                  192.168.1.3          Serial1/0
2.2.2.2 0                FULL/ –                  00:01:33                  192.168.1.2          Serial1/0

R1#sh ip ospf int s1/0
Serial1/0 is up, line protocol is up
Internet Address 192.168.1.1/24, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_MULTIPOINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:12
Supports Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 3.3.3.3
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)
R2#sh run int
*Mar 1 03:18:35.475: %SYS-5-CONFIG_I: Configured from console by console s1/0
Building configuration…

Current configuration : 287 bytes
!
interface Serial1/0
ip address 192.168.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.1 201 broadcast
frame-relay map ip 192.168.1.3 203 broadcast
no frame-relay inverse-arp
end

R2#sh run | s router ospf
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
neighbor 192.168.1.3
neighbor 192.168.1.1
R2#sh ip ospf nei

Neighbor ID              Pri    State              Dead Time              Address                 Interface
3.3.3.3 0                    FULL/ –                  00:01:30             192.168.1.3             Serial1/0
1.1.1.1 0                     FULL/ –                   00:01:57             192.168.1.1              Serial1/0
R3#sh run int s1/0
Building configuration…

Current configuration : 287 bytes
!
interface Serial1/0
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
serial restart-delay 0
frame-relay map ip 192.168.1.1 301 broadcast
frame-relay map ip 192.168.1.2 302 broadcast

no frame-relay inverse-arp
end

R3#sh run | s router ospf
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
neighbor 192.168.1.1
neighbor 192.168.1.2

R3#sh ip ospf nei

Neighbor ID                  Pri     State                   Dead Time                  Address                  Interface
1.1.1.1 0                      FULL/ –                          00:01:45                 192.168.1.1               Serial1/0
2.2.2.2 0                      FULL/ –                          00:01:31                  192.168.1.2              Serial1/0

“OSPF Network Çeşitleri -II-” için 2 cevap

  1. Salam Qardashlar. Men Azerbaycandan sizinle elaqe yaradiram. Sizin Forumu gordum chox beyendim , chox gozel ishlerle meshgulsuz , oyrenmek her zaman gozeldir , Sizlere tebrikler. Bunlari gordum mende uye oldum sizin siteye.

    Qardashlar sizlere 1 sualim var . 192.168.1.1/24 bu ip adresin mask adresi ne ? (255.255.255.xxx) ????

    1. ilginiz için teşekkür ederiz,

      sorunuza gelecek olursak,
      /24 prefix’i 255.255.255.0 subnet ini temsil etmektedir.
      ip adresinde bulunan 4 oktetlik (A.B.C.D) kısmındaki bit sayısını göstermektedir.
      /24 ‘ü binary olarak, 11111111.11111111.11111111.0
      şeklinde gösterilir.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir