Router-on-a-Stick Inter Vlan Konfigürasyonu

Merhaba,

Bu yazımda kısaca Router-on-a-Stick Inter-Vlan Routing konfigürasyonundan bahsedeceğim.

Router-on-a-Stick Inter-VLAN Routing, Inter-Vlan Routing’in fazla sayıda interface gerektirmesi üzerine bizi bu dertten kurtarabilen Inter-Vlan modelidir.  Basit bir topoloji konfigüre edecek olursak:

Router’da Konfigürasyon

//Router’ın Switch e bağlandığı port (fa 0/0) açılır.

Router>en

Router#conf t

Router(config)#int fastEthernet 0/0

Router(config-if)#no sh

Router(config-if)#ex

 

// 5 Vlan’i için subinterface (fa0/0.5) oluşturulup, encapsulation tipi belirtilir ve ip adresi atanır. (Burada VLAN numarasının “encapsulation dot1Q”  komutundaki numarayla aynı olması gerekmektedir. Subinterface oluşturulurken noktadan sonraki numaranın (fa0/0.5) ise Vlan numarası ile aynı olması gerekmez, sadece kolaylık olması için Vlan numarasıyla aynı girilmiştir.)

Router(config)#int fastEthernet 0/0.5

Router(config-subif)#encapsulation dot1Q 5

Router(config-subif)#ip address 192.168.5.254 255.255.255.0

Router(config-subif)#ex

 

//10 Vlan’i için subinterface (fa0/0.10) oluşturulup, encapsulation tipi belirtilir ve ip adresi atanır.

Router(config)#int fastEthernet 0/0.10

Router(config-subif)#encapsulation dot1Q 10

Router(config-subif)#ip address 192.168.10.254 255.255.255.0

Router(config-subif)#ex

 

 

Switch’de Konfigürasyon

//Switch’in Router’a bağlanan portu (fa0/24) açılır ve trunk moduna alınır.

Switch>en

Switch#conf t

Switch(config)#interface fastEthernet 0/24

Switch(config-if)#switchport mode trunk

Switch(config-if)#ex

 

//5 ve 10 Vlan’leri oluşturulur.

Switch(config)#Vlan 5

Switch(config-Vlan)#Vlan 10

Switch(config-Vlan)#ex

 

 

//Laptop1’in bağlandığı Switch portu (fa 0/1) access moduna alınır ve 5 Vlan’ine dahil edilir.

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access Vlan 5

Switch(config-if)#ex

 

 

//Laptop2’in bağlandığı Switch portu (fa 0/2) access moduna alınır ve 10 Vlan’ine dahil edilir.

Switch(config)#interface fastEthernet 0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access Vlan 10

Switch(config-if)#ex

 

Konfigürasyon sonunda;

Laptop1 den Laptop2’ye  gönderilen paketler switch’e giderek oradan trunk bağlantı üzerinden Router’in fa0/0.5 subinterface’ine gider ve Router’in  fa0/0.10 subinterface’inden yine aynı trunk bağlantı ile switch’e gelerek oradan Laptop2’ye gider. Trunk bağlantıdan geçen paketlerde vlan başlığı bulunmaktadır ve bu başlıkları Router subinterfaceleri altında yazdığımız “encapsulation dot1q”  komutu sayesinde tanır ve bir subinterface’inden diğerine aktardığı paketleri yine bu komut sayesinde vlan başlığı ekleyerek gönderir.

 

Bir sonraki yazıda görüşmek üzere…

Birkan Yıldızer

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir